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第一章　　UG NX运动仿真概述
1.1　运动仿真简介

运动分析模块（Motion Simulation）是CAE应用软件，用于建立运动机构模型，分析其运动规律。运动分析模块自动复制主模型的装配文件，并建立一系列不同的运动分析方案，每个运动分析方案均可独立修改，而不影响装配主模型，一旦完成优化设计方案后，可直接更新装配主模型以反映优化设计的结果。

Motion Simulation是NX用于机构运动的分析和建模。分析范围局限在刚体、静力和动力学领域。Motion Simulation 复制主装配模型，并对其多种方案进行分析求解，得到的最优方案可更新主装配模型以反映优化设计结果。
[image: image1.emf]运动仿真模块是基于刚体学进行运动分析的。

图1.1  机构学的分类
机构学（mechanics）：描述和预测物体在力和驱动作用下物体运动状态的一门学科

刚体静力学：研究物体静止状态的一门科学。物体永久不动、处于静止状态但有运动趋势、某一时刻处于匀速运动中的物体，均可认为其处于静止状态。意味着物体处于平衡状态，所有作用力之和为0，所以物体不运动。

例如：桥梁、支柱、支撑水箱的钢结构、承受载荷的托架和简支梁；待释放的悬挂钟摆、待释放的压缩弹簧、悬于半空的起重机吊装物；运动范围内连杆在某一时刻的瞬态分析。

刚体动力学：研究物体运动几何的一门科学。包括物体运动中固有几何运动和力学特性。比静力学复杂得多。

机构运动学：研究物体的位移、速度、加速度及其与时间的关系，而不考虑运动的原因。在机构运动学分析中，运动驱动是唯一考虑因素。其它的真正因素如作用力、摩擦力、重力、零件质量或重量均不予考虑。求解结果包含机构几何运动、速度、加速度、干涉情况和自锁条件等信息。即在假定条件下，解答在特定时间、特定位置物体之间的相互关系。不提供动力学方面的信息，如反作用力及机构中出现的动力学运动。可提供静态、瞬态平衡的反作用力信息。

机构动力学：研究作用在刚体上的作用力和该刚体的质量与运动之间关系的一门科学。机构动力学用于预测给定力所引起的运动或确定产生特定运动所需的力。可以考虑运动的真正因素，如作用力、摩擦力、个别组件的质量和惯性等，以及其他影响运动的因素。

UG NX机构运动仿真的主要用途如下：

进行机构的干涉分析。主要是研究机构运行时各个子系统或零件之间有无干涉情况，及时发现设计中的问题。

跟踪零件的运动轨迹。在机构运动仿真时，可以指定运动构建中任一点为参考并绘制其运动轨迹，这对研究机构的运行状况很有帮助。

分析机构中零件的速度、加速度、作用力、反作用力和力矩等。

运动分析模块的分析结果可以指导修改零件的结构设计（加长或缩短构件的力臂长度、修改凸轮型线、调整齿轮比等），或零件的材料(减轻或加重或增加硬度等)。设计更改可以反映在装配主模型的复制品分析方案，再重新分析，一旦确定优化的设计方案，设计更改可直接反映到装配主模型中。

1.2　运动仿真的工作界面

装配或部件主模型与运动仿真模型具有双向相关的关系：打开运动仿真界面后，软件自动复制主模型的装配或部件文件。运行UG NX，打开一个已经完成的装配图或部件，选择菜单【开始】/【运动仿真】如图1.2.1所示。
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	图1.2.1  开始菜单
	图1.2.2  运动导航器
	图1.2.3  【环境】对话框


在资源工具条上选择【运动导航器】，右键单击图形文件名，选择【新建仿真】如图1.2.3所示。选择【动力学】分析，单击【确定】按钮，如图1.2.3所示。

【动力学】考虑机构的质量，即连杆的重力，这样的运动仿真更接近机构运动的真实情况，全部应用动态分析机构的运动。

【基于组件仿真】方便在创建连杆时能快速选择装配组件。即无论这个组件多么复杂，在该选项下作为一个运动机构是不可再分的。对于不是装配体的主模型进行运动仿真时，不能选中该选项。

运动仿工作界面如图1.2.4所示。
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图1.2.4  运动仿真界面

1.3　运动仿真模块的参数设置

参数设置主要用于设置系统的一些控制参数，可以通过【首选项】下拉菜单或用户默认设置界面完成。

选择文件【实用工具】中【用户默认设置】命令，弹出用户默认设置对话框，如图1.3.1所示，在该对话框中可以设置求解器的类型及仿真环境。

图1.3.1  用户默认设置[image: image25.png]ERMHSRRR
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在UG NX运动仿真模块中，选择【首选项】下拉菜单【运动】命令，弹出运动首选项对话框，如图1.3.2所示。该对话框主要用于设置运动仿真的环境参数，如运动对象的显示、单位、重力常数、求解器参数和后处理参数等。
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图1.3.2  运动首选项

1.4　运动仿真的主要步骤

通过UG NX进行运动仿真的一般步骤如下：

新建一个运动仿真；
构建运动模型，包括设置每个零件的连杆特性，包括指定连杆的材料属性；
设置两个连杆间的运动副和添加机构载荷；
新建解算方案并求解，进行运动参数的设置，提交运动仿真模型数据，同时进行运动仿真动画的输出和运动过程的控制；
输出运动分析结果的数据，绘制表格、变化曲线，人为的进行机构运动特性的分析。 
第二章　　连杆、质量及材料特性

2.1　连杆的定义

在UG NX运动仿真中，连杆（Links）是组成机构的基本要素，机构中所有参与当前运动仿真的部件都必须定义为连杆，连杆的质量、中心、初速度等属性直接关系到运动分析的结果是否准确。连杆是代表刚性体的机构特征。当创建连杆时，需要指定定义连杆的几何体。可以认为机构就是“连接在一起的运动的连杆”的集合。

2.2　创建连杆、定义质量特性
在UG NX运动仿真中，只有将创建好的组件模型定义为连杆，才能在组件中添加运动副。定义连杆需要指定一个几何体对象，几何体对象可以是二维的，如草图、平面曲线等；也可以是三维的，如曲面、实体等。同一个几何对象只能属于一个连杆，定义连杆时可以选择独立的几何体，也可以选择一个零件，还可以将数个几何体或零件同时选中定义为一个连杆。

可以选择下述任意一种方法创建连杆：

从运动工具条或连杆和运动副工具条中单击图标[image: image4.png]


。

在运动仿真导航器上用鼠标右键单击仿真节点，并在弹出的快捷菜单中选择Link命令。

选择Insert中Link命令。

在连杆对话框中还可以定义质量特性。在运动仿真中，质量特性是一个可选项，可以打开或关闭（即可以考虑或不考虑）。

当不关心反作用力时，可以忽略质量特性。而当需要分析反作用力或作动力学分析时，则必须考虑质量特性，必须为每个连杆输入质量特性，包括质量、质心和惯性矩。

当机构中的连杆没有质量特性时，不能进行动力学分析和反作用力的静力学分析。没有质量的连杆有纯线框对象及无厚度的片体。

解算器利用质量特性计算机构中的反作用力。根据连杆中的实体，系统可以按默认设置自动计算质量特性。在大多数情况下，这些默认计算值可以生成精确的运动仿真结果。在某些情况下，用户必须人工输入质量特性，而不接受系统默认值。具体方法如下：

在连杆对话框中的【质量特性选项】区域选择用户自定义选项，如图2.2.1。选择质量中心。定义点，用捕捉点工具条指定特定的点，如图2.2.2。从屏幕上选择质量中心的位置。输入质量值，该值必须大于0。定义连杆的惯性矩。定义惯性矩的原点、方向并输入数值。利用惯性坐标系定义惯性矩方位。定义质量惯性矩和质量惯性积分别输入惯性矩数值。
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	图2.2.1  质量特性选项
	图2.2.2  捕捉点工具条


2.3　定义连杆的材料
材料特性时计算质量和惯性矩的关键因素，NX的材料功能可用来创建新材料、检索材料库中的材料特性，并将这些材料特性赋给机构中的实体。

用NX建模的实体具有默认的密度值，由用户默认文件设定，通常设为7.83×10-6kg/mm3。在运动方针中，未分配特定材料的实体均采用此默认的密度值。装配主模型中已分配材料特性的实体，均可在随后的运动仿真模型中继承其材料特性。
在主菜单中选在【工具】命令【材料】菜单中【指派材料】，弹出如图2-3对话框，可以为实体指定一种材料。

[image: image29.png]


图2.2.3  指派材料对话框

第三章　　运动副与约束

3.1　运动副与自由度

运动副就是将机构中的连杆连接在一起，从而使连杆一起运动。另外，为了让机构做规律的运动，必须用运动副限制连杆之间的运动。在运动副创建前，机构中的连杆是在空间中浮动的，没有约束，具有如下6个自由度：

沿x方向的移动；
沿y方向的移动；
沿z方向的移动；
绕x方向的转动；
绕y方向的转动；
绕z方向的转动。
连杆定义完成后，可以通过添加运动副来限制连杆的运动，减少机构的自由度，使其可以按要求进行独立的运动。运动副具有以下两个作用：

允许所需的运动；
限制不要的运动。
在机构中添加运动副时，还要注意机构中的冗余约束。冗余约束是指连杆在已达到约束目的的情况下，依然向机构中添加与现有约束不冲突的运动副或连接。冗余约束一般不会影响机构的运动状态分析，但涉及机构的力分析时，必须考虑冗余约束的影响。
3.2　运动副的类型

在UG NX运动模块中，选择下拉菜单【插入】/【运动副】命令，弹出如图3.2.1所示运动副对话框，在运动副【定义】选项卡【类型】下拉列表中显示了系统所提供的运动副。
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图3.2.1  运动副对话框

1. 旋转副

旋转副是最基本的连接类型，可以实现两个连杆绕同一轴作相对运动。旋转副分为两种：一种为一个连杆绕着固定在机架上的轴旋转，如图3.2.2所示；另一种是两个连杆绕着同一个轴作相对旋转，如图3.2.3所示。旋转副对连杆约束5个自由度，但在旋转副的轴线方向对连杆没有自由度的约束。
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	图3.2.2  固定转动副
	图3.2.3  旋转副


 滑动副

滑动副可以实现两个相互连接件互相接触并保持相对的滑动。滑动副分为两种：一种是两个连杆做相对滑动，如图3.2.4所示；另一种是一个连杆在静止的表面上做滑动，比如：箱子在轨道上的滑动，如图3.2.5所示。滑动副对连杆约束5个自由度，只允许两个连杆沿着一条轴线相互移动。
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	图3.2.4  滑动副
	图3.2.5  固定滑动副


 柱面副

柱面副可以实现两个连杆沿着一条轴线滑动和旋转运动。柱面副分为两种：一种是两个连杆做相对滑动和旋转运动，如图3.2.6所示；另一种是一个连杆在静止的表面上做滑动和旋转运动，如图3.2.7所示。柱面副对连杆约束4个自由度，允许连杆沿轴线做相对滑动和旋转运动。
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	图3.2.6  柱面副
	图3.2.7  固定柱面副


 螺旋副

螺旋副实现一个连杆绕另一个连杆做相对螺旋运动。螺旋副分为两种：一种是一个连杆相对于另一个连杆做轴向的旋转和轴向移动，如图3.2.8所示；另一种是一个连杆相对于机架做轴向旋转和轴向移动，如图3.2.9所示。使用RecurDyn解算器时，一个螺旋副对连杆约束5个自由度。
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	图3.2.8  螺旋副
	图3.2.9  固定螺旋副


 万向节

万向节传动主要用传递工作过程中不断改变相对位置的两根相连轴的动力，采用万向节传动可以保证在轴向交角变化时可靠地传递动力。运动仿真中，万向节副可以实现让旋转轴线有夹角的两个物体，把运动有一个物体传递给另一个物体。它的类型只有一种：两个轴有一定夹角的连杆，如图3.2.10所示。万向节副对连杆约束4个自由度。
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	图3.2.10  万向节副符号
	图3.2.11  万向节副的方向


万向节副的原点是指连杆与连杆连接的关键点，连杆将在此点与连杆相连接传递动力。万向节副的方向指的是连杆的轴线方向，每一个连杆的方向都由各自的右手坐标系确定，坐标系的原点即为两个连杆的连接点，X轴方向即为连杆轴线方向，如图3.2.11所示。正确设置万向节原点和方向是保证运动仿真达到预期效果的前提。原点必须位于X1-X2交点上，要避免产生小于90°的万向节，若定义不恰当会出现自锁。

 球面副

球面副常用在球和较套的机构仿真中，它可以使两个连杆绕某点进行旋转，提供3个旋转自由度，如图3.2.12所示。在定义球面副时，只需要定义连杆和原点即可，球面副不能定义运动极限也不能作为驱动，如图3.2.13所示。

	[image: image41.png]
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	图3.2.12  球面副符号
	图3.2.13  球面副的运动特征


 固定副

固定副把连杆的运动全部限制住，使连杆对地是完全固定，相当于底座、支架等支撑。固定副限制6个自由度，如图3.2.14所示。

	[image: image43.png]




	图3.2.14  固定副符号


 平面副

平面副连接的连杆既可以在相互接触的平面上自由滑动，也可以绕着垂直于该平面的轴线进行相对旋转，提供两个平移自由度和一个旋转自由度，如图3.2.15所示，平面副不能作为运动驱动。在创建平面副时，定义的原点和矢量方向共同决定接触平面，其中原点决定平面的位置，矢量决定接触平面法向，如图3.2.16所示。
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	图3.2.15  平面副符号
	图3.2.16  平面副的运动特征


其它运动副

（1）等速：等速副连接两个连杆，有两个绕连杆Z轴的旋转自由度。

共点：共点可以定义运动仿真时两连杆中的点重合。

共线：共线可以定义运动仿真时两连杆中边线或轴线重合。

共面：共面可以定义运动仿真时两连杆中的平面重合。

平行：平行可以定义运动仿真时两连杆中的平面或直线平行。

垂直：垂直可以定义运动仿真时两连杆中的平面或直线垂直。

3.3　范例一 —— 活塞的运动仿真

本范例将为模型创建运动仿真，了解运动仿真工作流程。

1. 打开部件文件piston.prt并启动运动仿真模块。
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	图3.3.1  piston.prt


2. 新建运动仿真。

在运动仿真导航器上，右击piston.prt，选择【新建仿真】命令，弹出环境对话框，分析类型选择【动力学】，组件选项选择【基于组件仿真】，单击【确定】。
3. 创建连杆。

在工具条选择【连杆】，将支撑块定义为【固定连杆】，并将活塞、连杆和曲柄部件定义为【连杆】，【质量属性选项】下拉列表选择【自动】。
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	图3.3.2  piston.prt


4. 创建运动副。

本例中共有三个旋转副和一个滑动副，其中一个旋转副为带驱动旋转副，初始速度为60。以旋转副为例，在工具条选择【运动副】，在类型下拉菜单选择【旋转副】，在操作选项组【选择连杆】选择曲柄，【指定原点】选择曲柄中心，【指定方位】[image: image48.png]


选择平行于轴线方向。
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图3.3.3  创建运动副
5. 新建解算方案并求解。
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在运动仿真工具条选择【解算方案】，解算方案类型为【常规驱动】，在分析类型下拉列表选择【动力学/运动学】，【时间】输入6，【步数】输入350，选择重力方向为竖直向下，通过【确定】进行求解。

图3.3.4  解算方案
6. 动画演示。

在运动仿真工具条选择【动画】，单击[image: image5.png]


按钮，观察各部件之间的运动。

3.4　约束的类型

1. 点在线上

点在线上用于一个连杆的一点始终与另一连杆或者机架上的线保持接触，实现连杆上点始终在线上运动。对连杆约束2个自由度，所约束的点就是点在线上副的接触点。如图3.4.1所示，主要分为三种情况：a)点在固定曲线上运动；b)曲线沿着固定点运动；c)点曲线都不固定，相互运动。如果点和曲线的设计位置和装配位置不在同一位置，点在线上副会约束点和曲线在装配位置。
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	曲线移动
	点移动
	曲线和点均可移动

	图3.4.1  点在曲线上


2. 线在线上

线在线上用于一个连杆的曲线始终与另一连杆或者机架上的曲线保持接触并且保持线与线间的相切运动，如图3.4.2所示。对连杆约束2个自由度，线与线的相切点就是线在线上副的接触点。在运动仿真中，曲线和曲线不允许分离，必须保持接触并且相切。如果曲线和曲线的设计位置和装配位置不在同一位置，线在线上副会约束点和曲线在装配位置。

	[image: image53.png]BUSRRR A
R

Bz ey v

]

S
[mawspit

[ T TR

F7) A
v B
ENEH 9806. 650

BE A
£

RESSH

<






	图3.4.2  线在线上


3. 点在面上

用于两个连杆之间或者连杆与机架之间保持连杆上的点约束在一个面或者一组面上，实现连杆上点始终在保持面上，如图3.4.3所示。对连杆约束3个自由度，在运动仿真中，点在面上不允许分离，如果点和面的设计位置和装配位置不在同一位置，点在面上副会约束点和曲线在装配位置。例如：挡风玻璃刮水器。
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	图3.4.3  点在面上运动特征


3.5　范例二——阀门的运动仿真

本范例将为学生演示阀门模型创建运动仿真，从而了解线在线上副。

1. 打开部件文件valve_cam.prt并启动运动仿真模块。

2. 新建运动仿真。

3. 创建连杆。

共创建下述三个连杆：CAMSHAFT；ROCKER及连杆上曲线；VALVE和门阀上曲线。

4. 创建运动副。

共创建下述运动副：

连杆CAMSHAFT/ROCKER上创建固定旋转副，初速度均为60；

连杆VALVE上固定滑动副；

ROCKER上曲线和VALVE曲线、CAMSHAFT和ROCKER曲线，添加线在线上副。

5. 新建解算方案并求解。

6. 动画演示。

图3.5.1  [image: image55.png]


阀门运动仿真界面
3.6　连接副的类型

1. 齿轮副

齿轮副模拟的是两齿轮的啮合运动，通过定义两个旋转副的转速比率，实现齿轮机构的运动仿真，如图3.7.1所示。齿轮的啮合点（接触点）即为齿轮副的原点。在进行运动仿真前，最好先通过装配功能调整齿轮位置，使其啮合良好，如图3.7.2所示。
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	图3.7.1  齿轮副符号
	图3.7.2  齿轮副运动特征


2. 齿轮齿条副

齿轮齿条副模拟的是齿轮和齿条的啮合运动，其本质是建立旋转副和滑动副的关系，如图3.7.3所示。定义齿轮齿条运动副需要先定义齿轮的旋转副和吃跳的滑动副，在创建齿轮齿条副定义传动比。齿轮齿条运动副的原点是齿轮和齿条牙齿的接触点，如图3.7.4所示。
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	图3.7.3  齿轮齿条副符号
	图3.7.4  齿轮齿条副运动特征


3. 线缆副

线缆副也叫滑轮副，模拟物体在滑轮上的滑移运动，如图3.7.5所示。定义线缆副首先需要定义两个滑动副，再创建线缆副建立速度比率关系，如图3.7.6所示。一个滑动副移动时，另一滑动副也跟着移动可以是等速、同方向，也可以定义其它运动关系一快、一慢、两个滑动副运动方向相反等。
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	图3.7.5  线缆副符号
	图3.7.6  线缆副运动特征


第四章　　连接器

4.1　弹簧

弹簧是一个弹性元件，用于施加力和扭矩到它的附着对象上。运动仿真模块提供了拉伸和扭转两种弹簧。拉伸弹簧可以定义在两个连杆之间、连杆和框架或运动副之间，定义的弹簧是一个虚拟连接，在机构模块中不显示。可以指定弹簧的刚度和自由长度。弹簧的自由长度就是弹簧在不受力时的自然长度。

对拉伸弹簧，施加力的大小由方程
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决定，
[image: image7.wmf]k

为弹簧刚度系数，
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为位移。对扭转弹簧，施加扭矩的大小由方程
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决定, 
[image: image10.wmf]k

为弹簧刚度系数，
[image: image11.wmf]q

为角位移。
4.2　阻尼

阻尼是一个机构对象，它能消耗能量，降低运动响应，对物体运动起反作用力。阻尼经常用于控制弹簧反作用力的行为。例如在液压机构中，可以使用阻尼器代表减慢活塞运动的液体粘性力。运动仿真模块提高拉伸阻尼和扭转阻尼两种元件。阻尼力对运动响应起副作用，阻尼力是运动物体速度的函数，作用方向与物体的运动方向相反。

阻尼力的大小由公式
[image: image12.wmf]FCV
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决定，
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为阻尼系数，
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为物体的运动速度。
4.3　2D/3D接触

1. 3D接触

3D接触可以实现机构中两连杆之间的接触不穿透以及碰撞的模拟，3D接触还可以进行表面接触力、接触面积和滑动速度等参数的分析研究。3D接触在解算时，需要较长时间，接触面越复杂，解算时间越长。

可以用3D接触定义两个实体之间的接触，例如，轮子与路面之间的接触，轮子为作用体，路面为基础体。3D接触不支持运动学分析。有以下两种方法描述接触表面：

小面模型法：该方法类似于用Adams解算器的小面3D接触方法。

拟合法：用一组光滑的面来拟合面片，以改善接触的光滑程度和模拟的速度。

2. 2D接触

2D接触可用于平面中的曲线接触仿真，它结合了线在线上约束类型和碰撞载荷类型的特点，允许用户设置作用在连杆上的两条平面曲线之间的碰撞载荷。当两个共面的曲线或实体在运动中可能分离时，2D接触可以更精确的描述模型的运动响应。2D和3D接触的唯一区别是2D接触限制在二维平面中。

4.4　范例一—滑块联轴器

本范例将为学生演示滑块联轴器的运动仿真，从而了解3D接触。

1. 打开部件文件huakuailianzhouqi.prt并启动运动仿真模块。

2. 新建运动仿真。

3. 创建连杆。

本例中共四个连杆，包括：支架，左边半联轴器，滑块，右边半联轴器。

4. 创建运动副。

[image: image62.png]


本例中先创建两个旋转副和两个滑动副（滑块沿径向边矢量方向滑动），初速度360，观察联轴器运动结果。再删除两个滑动副，创建滑块和两个半联轴器的3D接触，设置如图4.4.1所示。

图4.4.1  3D接触对话框

5. 新建解算方案并求解。

时间1s，步数100步。

6. 动画演示。

第五章　　驱动与函数

5.1　恒定驱动

运动驱动是赋在旋转副、滑动副、柱面副等运动副上控制运动的运动副参数。运动驱动总是与运动副相关。可以定义一个默认的运动驱动，也可以创建一个仅于指定求解方案中的运动副相关的独立驱动。对任何运动副，在一个求解方案中只能包含一个独立驱动。

[image: image63.png]


在前面举例中，大多使用的是恒定运动驱动。恒定运动驱动设置运动副为恒定运动（旋转或平移），这类驱动所需参数为初始位移、初始速度和加速度。恒定驱动运动副是基于时间的运动仿真，其位移按下列公式计算：

5.2　简谐驱动

简谐驱动就是使用简谐函数驱动运动副中的位移变化。简谐函数波形为正弦曲线，它可以生成一个光滑的正弦运动。简谐振动共有4个参数，分别使幅值、频率、相位角和位移。运动副的位移按下列公式计算：
输出=B+A*sin(ω*t-φ)

输出=初始位移＋振幅*sin（频率*时间－相位角）

简谐函数曲线图形如图5.2.1所示。
[image: image15.png]



图5.2.1  简谐函数曲线图形
5.3　函数驱动

函数驱动用于给运动副添加一般的驱动。这个驱动是根据方程而变化的，函数驱动可以精确的控制连杆在某一时间段的运动轨迹。UG NX中XY函数管理器工具可以定义多种类型函数驱动，以阶梯函数STEP为例。

STEP（x，x0，h0，x1，h1）函数是3次多项式逼近阶跃函数，其定义为：
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其中，x为自变量，通常为时间（TIME）；x0为阶跃函数开始时的x值；h0为阶跃函数初始值；x1为阶跃函数终止时的x值；h1为阶跃函数终止值。

5.4　铰接运动驱动

铰接驱动又称为关节驱动，是通过设置运动副的运动步长及步数来驱动机构的运动，常用来观察机构每个步数的运行状况，以优化机构的设计位置。
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当运动驱动定义为铰接运动驱动时，机构的运动设置和分析均在铰接运动仿真对话框中进行，如图5.4.1所示。

图5.4.1  铰接运动驱动对话框
第六章　　分析与测量

6.1　分析结果输出

当解算方案求解完成后，除了可以使用【动画】工具输出机构的运动视频外，还可以对机构中某个连杆和运动副的速度以及位置数据进行输出。输出的方式主要有图表输出和表格输出，图表输出如图6.1.1所示。机构在运动时，系统内部将自动生成一组数据表，在运动分析过程中，该数据表连续记录数据，每一次更新分析，数据表都将重新记录数据，电子表格的数据与图形输出的数据一致。

图表功能可以生成电子表格数据库并绘出位移、速度、加速度和力的仿真结构。图表功能是从运动仿真分析中提取这些信息的唯一方法。
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	图6.1.1  图表对话框
	图6.2.2  速度-时间曲线


6.2　标记与智能点

标记和智能点用于分析机构连杆中某一处的运动学和动力学数据。当要分析与测量某一点的位移、速度、加速度、力、弹簧的位移、弯曲量以及其它运动学和动力学数据时，均会用到此类测量工具。

1. 标记

标记是在连杆中制定一个点的位置，用与分析、研究连杆该点处的机构数据。标记不仅与连杆有关，而且需要有明确的方向定义。标记的方向特性在复杂的动力学分析中非常有用，常用于分析某个点的线性速度或加速度以及绕某个特定轴旋转的角速度和角加速度等。
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	图6.2.1  标记对话框


2. 智能点

智能点用于在机构空间中创建一个位置参考点。只能点不会作为连杆的一部分，与连杆也完全无关，知识单纯作为位置参考，智能点也可以作为运动副和弹簧的创建参考。在进行图形和表格分析输出时，智能点不能作为可选对象，只有标记才能用于图表功能在，但是智能点可以作为标记的放置参考。

智能点的创建方法与普通电的创建方法完全一样。
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	图6.2.2  智能点对话框


6.3　干涉、测量与跟踪

干涉、测量与跟踪可以用于检查机构中的动态干涉和最小间隙，获得机构的特定运行位置，以便对设计进行进一步改进。主要这里的测量工具不是获得位置和角度曲线，只是限定极限距离后设置机构在这些位置停止，要想得到准确的距离和角度数据，必须使用标记工具。

1. 干涉

干涉检查功能可以用于检查机构的动态干涉，如图6.3.1所示。定义干涉时需要预先定义两组检查实体，然后在动画中启动干涉检查，即可以定义机构在干涉时停止运动。
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	图6.3.1  干涉对话框


2. 测量

测量功能可以用于定义机构中一组几何体的极限距离和极限角度，当机构的运转超出极限范围时会自动停止，如图6.3.2所示。
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	图6.3.2  测量对话框


3.追踪

追踪功能可以在机构运动的每一个步骤中创建一个复制的指定几何对象，追踪的几何对象可以是实体、片体、曲线以及标记点，如图6.3.3所示。当追踪对象为标记点时，可以用于分析、查看机构中某个点的运动轨迹。
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	图6.3.3  干涉对话框


第七章　　有限元分析概述

7.1　ANSYS简介

ANSYS是一种广泛的商业套装工程分析软件。所谓工程分析软件，主要是在机械结构系统受到外力负载所出现的反应，例如应力、位移、温度等，根据该反应可知道机械结构系统受到外力负载后的状态，进而判断是否符合设计要求。一般机械结构系统的几何结构相当复杂，受的负载也相当多，理论分析往往无法进行。想要解答，必须先简化结构，采用数值模拟方法分析。由于计算机行业的发展，相应的软件也应运而生，ANSYS软件在工程上应用相当广泛，在机械、电机、土木、电子及航空等领域的使用，都能达到某种程度的可信度，颇获各界好评。使用该软件，能够降低设计成本，缩短设计时间。
到80年代初期，国际上较大型的面向工程的有限元通用软件主要有：ANSYS, NASTRAN, ASKA, ADINA, SAP等。以ANSYS为代表的工程数值模拟软件，是一个多用途的有限元法分析软件，它从1971年的2.0版本与今天的5.7版本已有很大的不同，起初它仅提供结构线性分析和热分析，现在可用来求结构、流体、电力、电磁场及碰撞等问题的解答。它包含了前置处理、解题程序以及后置处理，将有限元分析、计算机图形学和优化技术相结合，已成为现代工程学问题必不可少的有力工具。

ANSYS软件是融结构、热、流体、电磁、声学于一体的大型通用有限元软件，可广泛的用于核工业、铁道、石油化工、航空航天、机械制造、能源、汽车交通、国防军工、电子、土木工程、生物医学、水利、日用家电等一般工业及科学研究。该软件提供了不断改进的功能清单，具体包括：结构高度非线性分析、电磁分析、计算流体力学分析、设计优化、接触分析、自适应网格划分及利用ANSYS参数设计语言扩展宏命令功能。
7.2　ANSYS分析步骤

ANSYS分析过程包含三个主要的步骤：

1. 创建有限元模型
创建或读入限元模型
定义材料属性
划分网格
2. 施加载荷并求解
施加载荷及设定约束条件
求解
3. 查看结果
查看分析结果
检查结果是否正确
7.3　静力学分析实例

7.3.1 悬臂梁分析实例
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下图所示一根悬臂梁，梁长2m，截面为工字型，截面尺寸如图所示；梁悬伸末端作用有20kN的集中力；梁的弹性模量为200GPa，泊松比为0.3。试用ANSYS软件求该梁的挠度及应力分布。梁长度方向划分10个单元，采用beam3单元。

图7.3.1  悬臂梁

1 进入ANSYS 
   以交互模式进入ANSYS，工作文件名为beam_001

前处理Preprocessor
2 设置计算类型 

   Preferences →select Structural → OK 

3 选择单元类型 
   Preprocessor →Element Type→Add/Edit/Delete →Add→select Beam 3 →OK 

4 定义实常数 
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图7.3.2  Beam Tool

Preprocessor →Section→Beam→Common Section

Beam Tool…→Sub-Type→W1=W2=W3=0.2，T1=T2=T3=0.03→Preview
Preprocessor →Real Constants… →Add… →select Type 1→ OK→input AREA=0.0162,IZZ=0.945E-4,HEIGHT=0.2 →OK →Close

5 定义材料属性

    Preprocessor →Material Props →Material Models →Structural →Linear →Elastic →Isotropic →input EX:2e11, PRXY:0.3 → OK
6 生成几何模型
 关键点和线

   Preprocessor→Modeling→Create→Keypoints→In Active CS→1(0,0),2(2,0)→OK    

   Preprocessor →Modeling →Create →Lines →Lines →Straight Line →OK
7 网格划分 

    ANSYS Main Menu: Preprocessor →Meshing →Mesh Tool→(Size Controls) lines: Set →Pick All :OK→input NDIV: 10 →OK →(back to the mesh tool window)Mesh: lines →Mesh→ Pick All (in Picking Menu) →Close
求解Solution
8 模型施加约束 

给1施加约束:

Solution →Define Loads →Apply →Structural →Displacement → On Keypoints →拾取1→Apply →select Lab2:ALL DOF → OK
给右端添加集中力

Solution →Define Loads →Apply →Structural →Force/Moment →On Keypoints →拾取点2→OK →Lab: FY, Value: -20000→OK 
9 分析计算 
ANSYS Main Menu: Solution →Solve →Current LS →OK(to close the solve Current Load Step window) →OK 
后处理General Postproc

10 结果显示 
ANSYS Main Menu: General Postproc →Plot Results →Deformed Shape… → select Def + Undeformed →OK (back to Plot Results window) 

11 结果显示 
存储ANSYS数据库.Toolbar: SAVE_DB
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图7.3.3  分析结果
7.3.2 平面问题分析实例

一等腰直角三角形薄板如图所示，已知直角边AB和BC的长度为1m，板厚为0.01m；在板上图示位置有一半经为0.1m的通孔；薄板左侧一条直角边固定，在斜边AC上施加压强为1000Pa的载荷，载荷方向与AC相垂直；薄板的弹性模量为200Gpa，泊松比为0.3。试用ANSYS软件的SHELL63单元，三角形板总体网格划分尺寸为0.03m。求出薄板的变形形状、应力分布，将结果存放在数据文件中。
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图7.3.4  三角板
1 进入ANSYS 
   以交互模式进入ANSYS，工作文件名为plane

前处理Preprocessor
2 设置计算类型 

   Preferences →select Structural → OK 

3 选择单元类型 
   Preprocessor →Element Type→Add/Edit/Delete →Add→select Shell 63 →OK
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图7.3.5 单元类型设置
4 定义实常数 

   Preprocessor→Real Constants…→Add…→select Type 1→OK→Shell thickness at I TK(I)= 0.01→OK →Close
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图7.3.5 实常数设置
5 定义材料属性

    Preprocessor →Material Props →Material Models →Structural →Linear →Elastic →Isotropic →input EX:2E11, PRXY:0.3 → OK
6 生成几何模型
 生成三角形和圆并求差

   Preprocessor→Modeling→Create→Keypoints→In Active CS→1(0,0),2(1,0) ,3(0,1)→OK    

Preprocessor →Modeling →Create →Lines →Lines →Straight Line →OK
Preprocessor →Modeling →Create →Areas →Arbitrary→by Lines →拾取3条直线→OK
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图7.3.6  建模过程
Preprocessor→Modeling→Create→Areas→Circle→Solid Circle

    WPX=0.2,WPY=0.2,Radius=0.1
Preprocessor →Modeling →Operate→Booleans→Subtract→Areas
7 网格划分 

    ANSYS Main Menu: Preprocessor →Meshing →Mesh Tool→(Size Controls) Global: Set →SIZE:0.03→OK →Mesh→ Pick All →OK→ close
求解Solution
8 模型施加约束 

给边施加约束 

Solution →Define Loads →Apply →Structural →Displacement → On Lines →拾取竖直边→Apply →select Lab2:ALL DOF → OK 
给边施加线性分布载荷

Solution →Define Loads →Apply →Structural →Pressure →On Lines →拾取斜边→OK →VALUE 1000→OK 

9 分析计算 
Solution →Solve →Current LS →OK(to close the solve Current Load Step window) →OK 
后处理General Postproc

10 结果显示 
General Postproc →Plot Results →Contour Plot →Nodal Solu… →select: stress, Von Mises Stress →OK 11 结果显示 
存储ANSYS数据库.Toolbar: SAVE_DB
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图7.3.7   分析结果
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